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1. ABOUT THE DOCUMENT 

This document provides key information on FlexiCapture 9.0 installation, setup and processing. For more 

information, see the “New Features in FlexiCapture 9.0” document with detailed description of all new features. 

 

2. ABOUT THE PRODUCT 

ABBYY FlexiCapture 9.0 belongs to the new generation of ABBYY’s data capture solutions. It provides efficient 

and accurate data extraction from forms and documents for subsequent data export into databases and 

business systems. ABBYY FlexiCapture 9.0 includes all functionality of FlexiCapture 8.0 Professional and 

extended functionality that provides means for distributed processing across enterprise.  

FlexiCapture 9.0 has two different installation types: 

 Standalone 

 Distributes 

 Server 

The type of installation is selected during the installation of the product. For each installation type a different 

serial number is used. 

 

2.1 Distributive and Build Number 

Distributive number: Part # 538-7  

Build number:  9.0.3.2438 

 

3. INSTALLING AND ACTIVATING THE PRODUCT 

To use the product, you need to have the Serial Number. You can install FlexiCapture 9.0 on the same computer 

where previous versions (FlexiCapture 8.0 Professional) are installed. 

 

3.1 Software and hardware requirements 

For the proper work of our applications we recommend to use computers with the following characteristics listed 

below. 
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System requirements: 

- Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™, AMD 6/Turion™/Athlon™/Duron™/Sempron™ 

processor or compatible 

- Min. 2 GHz 

 

Operating system: 

- For Verification, Data Verification and Scanning Station (Standalone or Distributed): 

o Windows XP SP2 x86,  

o Windows Vista SP1 x86 + Hotfix for Windows (KB959489) 

 

- For Servers (Distributed and Server): 

o Windows Server 2003 SP2 x86 

o Windows Server 2008 x86 + Hotfix for Windows (KB959489) 

For the program to run with a localized interface, the operating system must provide the required language 

support.  

- RAM: 512 Mb for every CPU core; but not less 1 Gb total 

- Free hard-disk space: 

o Standalone: 1 Gb (including 700 MB for installation)  

o Distributed/Stations: 1 Gb (including 800 MB for installation) 

o Server: 1 GB (including 800MB for installation) 

o Database Servers: 50 MB for installation + 2 Gb for the Database of SQL server 

- Scanner supporting TWAIN, WIA or ISIS.  

- Internet connection to activate the serial number when using a software protection key or a USB port for 

a hardware protection key (dongle).  

- Video card and display with a resolution of 1024×768. 

- Keyboard, mouse or other pointing device. 

 

3.2 New Installation of FC9 R3 

The installation type (Distributed or Standalone) can be selected from Autorun. To install the product, you can run 

the correspondent “Setup.exe” file or use the Autorun. Follow the instructions of installation wizard. Please note 

that you need to have local administrative rights to install the product. 

 

3.2.1 Standalone installation 

For Standalone type, only the local installation is available, no network installation. Please select the 1st option 

from the Autorun Installation Menu.  
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Setup Types: 

One setup type is supported: 

- Administrator Station. Installed components: Administrator Station, FlexiLayout Studio, FormDesigner for 

Document Definitions and Layout development. 

 

All other program components (all recognition languages, UI languages, Samples) are installed by default. Setup 

Type Standalone allows installation of only Administrator station or Operator station on a Workstation Computer.  

Please make sure, that you have the correct serial number for you installation (Administrator station or Operator 

station).  
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3.2.2 Distributed Installation 

 

 

 

Installation requirements  

(Please read carefully before installing the Distributed Installation Type) 

The following conditions must be met to install Application Server and Administration and Monitoring Console. On 

the one and the same computer the following items must be installed (Installation order): 

 

1. Installation of External components first (all programs available on FlexiCapture 9.0 Distributive, you can 

install it using Autorun >> Distributed Installation >> Additional Programs): 

 

a. Install .Net Framework 2.0 or higher  

 

b. IIS (Internet Information Services) version 6 or 7, which is installed as a Windows component : 

 

In case of Windows Vista or Windows 2008, these components must be installed (see 

Screenshot): 

>> Web Management Tools 
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>> IIS 6 Management Compatibility 

                 >> IIS 6 Metabase and IIS 6 configuration compatibility 

                 >> IIS 6 Scripting Tools 

>> World Wide Web Services 

               >> Application Development Features 

                       >> ASP.NET 

                       >> ISAPI Extensions 

               >> Security 

                       >> Windows Authentication 

 

c. Crystal Reports Basic Runtime for Visual Studio 2008:  

Should be installed for proper work of Administration and Monitoring Console. 

 

If one of required components listed above is not installed, 

the correspondent message will be displayed, and the 

installation won’t be possible until all necessary 

components are properly installed. 

The following programs are not required for the installation 

but are necessary for the work so we recommend installing 

them before installing the servers as well (SQL Server could 

be installed after other servers and stations but we 

recommend installing SQL Server before). 

 

d. SQL Server 2005 or 2008: 

For Application Server’s work the SQL 

Server 2005 or 2008 is required. In the 

SQL Server, the "Mixed Mode" for 

authentication must be turned on. Mixed 

Mode is sometimes also called "SQL server 

and Windows authentication". (MS SQL 

Express Edition is available on FlexiCapture 

9.0 disk, you can install it using Autorun > 

Distributed Installation > Additional 

Programs). 

 

e. Internet Explorer 6, 7, or 8 (in compatibility 

mode).  

The work with other browsers hasn’t been 

tested for the Beta Version. 
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After installing the Additional Programs (.Net Framework, IIS, Crystal Reports, SQL Server) you may start installing 

the FlexiCapture components. 

 

Installation on Windows 64 Bit Operating systems 

You may install FlexiCapture Distributed on 64 Bit operating systems as well. For you may need 64 Bit external 

components, which cannot be installed from Autorun Menu. Please refer to the folder external components on 

the Distributive and change to the folder 64 Bit to install SQL Server for 64 Bit operating systems.  

 

Installation components 

Before installing Application Server, please check if you have additional software installed on the same 

computer. All additional components (except IIS) can be installed from our DVD. To find them, use the Install 

External Components item of Autorun.  

The whole installation for the distributed version has two parts: 

1. Server installation 

2. Workstations installation 

The server installation consists of the following components: 
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1. Application server + Administration and Monitoring Console (Web application) 

2. Licensing server 

3. Processing server 

Workstations installation (client part) consists of: 

1. Project Setup Station 

2. Scanning Station 

3. Verification Station 

4. Data Verification Station 

5. Processing Station 

6. FlexiLayout Studio 

7. FormDesigner 

 

2. Installation of the servers (Autorun >> Distributed Installation >> Install servers):  

The servers can be installed either in one computer or in different, by default they will be installed in one 

computer. During the installation of Application Server it is possible to install a special administrative image of 

the workstations installer. This installer supports distributed installation scenarios: by SMS or AD. 

 

3. Install workstations (Autorun >> Distributed Installation >> Install workstations):  

Workstations installation can be carried out using this image or common installation from the CD. During the 

installation you should indicate a path to the License Server. SQL Server can be installed before or after other 
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servers and stations. Each component may be installed on a separate computer. To do it, you must disable the 

rest of the components when installing on a different server.  

 



 

Page 10 
 

 

 

3.2.3 Server Installation 

 

1. The Server installation type requires the Installation of External components first (all programs available on 

FlexiCapture 9.0 Distributive, you can install it using (Autorun >> Distributed Installation >> Additional 

Programs). 

 

A detailed instruction of how to install the external components, please follow the instructions in distributed 

installation. 

 

Installation on Windows 64 Bit Operating systems 

You may install FlexiCapture Distributed on 64 Bit operating systems as well. For you may need 64 Bit external 

components, which cannot be installed from Autorun Menu. Please refer to the folder external components on 

the Distributive and change to the folder 64 Bit to install SQL Server for 64 Bit operating systems.  

 

Installation components 

Before installing Application Server, please check if you have additional software installed on the same 

computer. All additional components (except IIS) can be installed from our DVD. To find them, use the Install 

External Components item of Autorun.  

The whole installation for the distributed version has two parts: 
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1. Server installation 

2. Project Setup Station and Design Tools installation 

The server installation consists of the following components: 

1. Application server + Administration and Monitoring Console (Web application) 

2. Licensing server 

3. Processing server 

Stations installation (client part) consists of: 

1. Project Setup Station 

2. Processing Station 

3. FlexiLayout Studio 

4. FormDesigner 

 

2. Installation of the servers (Autorun >> Distributed Installation >> Install servers):  

The servers can be installed either in one computer or in different, by default they will be installed in one 

computer. During the installation of Application Server it is possible to install a special administrative image of 

the workstations installer. This installer supports distributed installation scenarios: by SMS or AD. 
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3. Install workstations (Autorun >> Distributed Installation >> Install workstations):  

Workstations installation can be carried out using this image or common installation from the CD. During the 

installation you should indicate a path to the License Server. 

 

Please make sure, that you manually only select the stations like shown on the Screenshot below. Server 

installation type licenses allows only to install Processing Station, Project Setup station and additional Graphical 

Design Tools for Fixed Forms and FlexiLayout Development. 

 

In the installation menu, please select the stations as described below. You need to install the following 

components for FlexiCapture Server: 

1. Processing Station (processing of documents) 

2. Project Setup Station (Setup of Projects) 

3. FlexiLayout Studio and FormDesigner (for development of Templates) 
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3.2.4 (Remote) Scanning and (Remote) Data Verification Station installer 

An independent installer is available for the Remote Scanning Station. Select the Distributed Installation and 

then the Install Remote Scanning Station item in the Autorun, or run Setup.exe for Scanning Station.The 

Scanning Station installed using a separate installer can work in remote mode. You will need a separate Serial 

Number for the Scanning Station. If you need a local Scanning Station, which will work in the same domain with 

other servers and stations, use common installer for stations (Autorun > Distributed Installation > Install 

Workstations). In this case, you don’t need a separate Serial Number; the quantity of local Scanning Stations is 

indicated in FlexiCapture 9.0 Serial number. 
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3.3 Updating from FC9 prior Releases 

3.3.1 Update to FC9 R3  

To update to the new version, it is necessary to start installation of the new release. If one of the prior Releases 

was installed on the same computer, the installer will detect it and update the program (uninstall the old version 

and install the new one in the same configuration). 

 

3.3.2 Update from Distributed and Server to Release 3 

Before starting the update, it is recommended to stop the Processing Server and Processing Station using the 

Processing Server Monitor, and stop all the stations running on the computer on which the update will be done. 

During installation you may get asked to close Processing Server and Protection Server. You can do that by 

stopping the relevant services: got to Control panel, Administrative tools and select the services section. You 

must stop ABBYY FlexiCapture Protection Server, FC Processing Server and FC Processing Station. 

There is no need to re-install additional components (IIS, .NetFramework, SQL server, Crystal Reports). After the 

upgrade, you may only need to turn on the basic authentication in IIS again if it was used (for example, for 

remote stations). You can use the same Database and the same File Storage. 

To update your Database, click the link “Update to required version” on the Administration and Monitoring 

Console (Settings > Application Server): 

 

Please note that projects opened in the new version cannot be opened in previous versions. Known issue: for 

correct work all Batch Types created in previous version must be re-saved. 

3.4 Alternatively: Uninstall prior versions 

If you installed FlexiCapture Release 2 you can also uninstall the prior licenses the process manually.  
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3.4.1 Un-install of prior Releases 

Please uninstall FlexiCapture 9.0 Servers and Stations from the Uninstall Menu. Please be aware that you only 

should uninstall FlexiCapture 9.0 Servers and FlexiCapture 9.0 Stations and not the external components. 

 

3.4.2 External components 

There is no need to re-install additional components (IIS, .NetFramework, SQL server, Crystal Reports). After the 

upgrade, you may only need to turn on the basic authentication in IIS again if it was used (for example, for 

remote stations). You can use the same Database and the same File Storage. Please note that projects opened 

in the new version cannot be opened in previous versions.  

Known issue: for correct work all Batch Types created in previous version must be re-saved. 
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3.4.3 Database update 

To update your Database, click the link “Update to required version” on the Administration and Monitoring 

Console (Settings > Application Server):  

 

 

3.5 Activating the product 

At the end of the installation, the following License Manager dialog box will appear (you can always launch it later 

from the Start menu): 
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Click the “Add license…” button. Then, in the following dialog box, type your Serial Number and click the “Next” 

button. 

 

In the next dialog box that appears, select an activation method – via the Internet (recommended) or by e-mail. 

Click “Next”, and the activation will be performed.  

 

 

4. PRODUCT SETUP 

To setup the complex we recommend that you go through following steps: 

1. Select the distributed installation type. Install the program following the instructions of installation wizard 

and Installation section of this document. 

2. Activate your serial number. See the Activating the product section. 

3. Open the Administration and Monitoring Console. (It will be opened automatically after installation). 

Create the Database. Mark Set file storage if you want to use file storage, otherwise all project files will 

be saved in the Database (a database of big size may be needed). The path to the File Storage is a local 

path to the folder on the Application Server. Note. The user can decide whether to use the File Storage or 

not. The productivity and security is equal in both cases. If the data are stored in the DB, it is easier to 

make backup, but the size of DB may significantly increase, which is not convenient for Microsoft SQL 

Server Express Edition, which has limitation of DB size (4 Gb). 
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4. Now you need to upload some project to the Application Server. Open the Project Setup Station. You can 

do one of the following: 

 Create a new project (File>New Project…). Create at least one Document Definition (Project > 

Document Definitions).  

 Open one of the sample projects  

(You can find the sample projects in <disk name>:\\Documents and Settings\All Users\Application 

Data\ABBYY\FlexiCapture\9.0\Samples. 

Under Microsoft Windows Vista, the sample projects can be found in <disk 

name>:\\Users\Public\ABBYY\FlexiCapture\9.0\Samples.) 

 Open your project created in FlexiCapture 8.0 Professional (See Using FlexiCapture 8.0 Professional 

projects (*.fcproj)). 

 Create a new project and import your batch created in FormReader 6.5 DE or EE (See Using 

FormReader 6.5 batches (*.frm)). 

Check that your project has at least one valid and enabled Document Definition and the Export Settings 

are properly defined in it. 

Then upload the project to Application Server (menu item File>Upload Project to Server). Type the name 

of your Application Server in the dialog box that appears. 
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5. Go to the Settings>Users and Groups page of the Administration and Monitoring Console. Select the 

created project from the Project control. Grant rights to one or more users. Note. The user who created a 

Database will have administrator’s rights and will be able to open all stations and execute all kind of 

operations.To add a new user: click the Add… button and type the user’s name as defined in your 

domain. 

To grant rights to the user: mark one or several roles for the user. For the roles of Scanning operator, 

Data Verification Operator, Verification Operator and Senior Verification Operator you will also will need to 

indicate allowed batch types. (Other roles have rights for all batch types). 

To select batch types allowed to the user, mark the checkboxes with allowed batch types after selecting 

the role. If you cannot see batch types, click the link Show details… to the right of the selected role name.  
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You can also grant rights to the group of users. Using groups will save your time and make working with 

users easier.  

Note. You can assign roles of Administrator, Monitoring Operator and Processing server without creating 

any project in the database. All other rights depend on the project, so the project should be created first. 

To create a group: click Groups, then click the Add… button and type the name of the group. Click Save.  

Select the role and batch types. This role and rights to the batch types will be assigned to every user 

which will be added to the group. 

To add users to the group: select users in the right window Users and move them to the left side.  

 

 

 

IMPORTANT! It is necessary to assign the role Processing server to the account of "Network service" of 

the computer where the Processing Server had been installed. If that computer is in the domain, the 

account name is: <Domain name>\<Computer name>$  

(For example, FINE\Quad-1$) 
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6. Open the Processing Server Monitor (Start menu > ABBYY FlexiCapture 9.0 Servers > Processing Server).  

Configure the Processing server. Select Action > Properties and type the path to the Application Server. 
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Start the Processing Server by clicking  (Start Server). 

Then add Processing stations. To add a station, select Stations in the tree and click  (Add Station). 

Type the computer name where the Station is installed. 

 

To launch the Station, select it from the list and click  (Start Station). 
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7. To define how the documents will be processed, use Project Properties (Project > Project Properties…) or 

create several Batch Types (Project > Batch Types) on the Project Setup Station. If you create several 

Batch Types, you’ll be able to process batches in different ways assigning different Batch Types to them. 

If you have no Batch Types, the Project Properties will be used by default.  

 

5. PROCESSING DOCUMENTS 

1. To import images use the Scanning Station. Open the Station and create a new batch. Scan images or 

add them from the folder. Send the batch to server (Export > Send to FlexiCapture…). Browse for the 

previously created project (see item 4). You can assign the created batch type to the batch (see item 7). 

You can check if the recognition task is executed on the processing station by using the Processing 

Server Monitor. 

You can also see statistics on the Administrator and Monitoring Console. 

2. It is also possible to use Hot Folders for import images. To use a Hot Folder, create an Image Import 

Profile which will use Hot Folder on the Project Setup Station (Project>Image Import Profile…). In the 

properties of this Hot Folder Profile, the “Check Hot Folder every … seconds” option must be selected. 

Don’t use the option “Add images to current batch” – there is no current batch for distributed processing. 

This option can only be used for testing project locally. 
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From the Processing Server Monitor, enable possibility of using the Hot Folder in your project.  
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3. To compare recognized data with image, use the Data Verification Station. The interface of this station is 

simple; no special preparation is needed to work on this station. The operator should have the Data 

Verification Operator role to work on this station. 

To start working, the operator must click the Get Task button, verify the data, then click the Return Task 

button. 

 

 

4. To verify data logic, assembling and rules errors, batch integrity etc. use Verification Station.  

The users with roles: Data Verification Operator, Verification Operator and Senior Verification Operator 

can work on this station. The list of available queues depends on the operator’s role. 

The Data Verification Operator can execute here the same operations like in the Data Verification Station. 

Only the Data Verification queue will be available for this operator. 

The Verification Operator can process tasks from the following queues: 

 Document Assembly Check 

 Data Verification 

 Verification 

 Batch Integrity Check 

The Senior Verification Operator can process tasks from the following queues: 
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 Document Assembly Check 

 Data Verification 

 Verification 

 Batch Integrity Check 

 Export Confirmation  

 Exceptions 

To check the queues, the operator must click View > Queues. To get a task from any queue, select the 

line <Any> and click the Get Task button. If you previously select a queue, this command will allow you to 

get task from the selected queue. 

 

 

 

For more information on workflow and queues, see the “New Features in FlexiCapture 9.0” document.  

 

6. USING FLEXILAYOUTS AND TEMPLATES FROM PREVIOUS VERSIONS 

6.1 Using projects created in FlexiCapture 9.0 Beta 

All FlexiCapture 9.0 project files (.fcproj) created in the Beta version of the Standalone installation can be opened 

and used in FlexiCapture 9.0 Release 1 without any additional changes. The same is true for projects created in 

the Distributed installation and stored locally. 

To open and use projects created in the Beta version and uploaded to the Application Server, please do the 

following: 

- Prior to installing FlexiCapture 9.0 Release 1, open the project on the Project Setup Station and save it on 

this station by selecting Project -> Export Project… from the menu. 

- Install the FlexiCapture 9.0 Release 1. 
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- Create a new database, because Release 1 uses a different database format. 

- On the Project Setup Station, browse to the folder where you saved the project and click Open.  

- Upload the project to the Application Server. 

 

6.2 Using FlexiCapture Studio 1.5 and FlexiLayout Studio 8.0 Projects (*.fsp) 

All FlexiCapture Studio 1.5 and FlexiLayout Studio8.0 projects can be opened in FlexiLayout Studio 9.0 – no 

conversion is needed. Please note the following: 

- It is impossible to open an .fsp-project in previous versions once it was opened in FLS 9.0, so create a copy of 

the project before opening it in FLS 9.0 if you still need to open it in FCS 1.5 or FLS 8.0. 

- After opening a project in FLS 9.0 you may need to delete all processing results and analyze all pages once 

again. 

- Due to changes in FlexiLayout language some compilation errors may occur. In this case you will need to 

correct errors and re-compile FlexiLayouts. 

 

6.3 Using FlexiLayouts (*.afl) Created in FlexiCapture Studio 1.5 or in FlexiLayout Studio 8.0  

All FlexiLayouts compiled in FCS 1.5 or FLS 8.0 can be loaded into FlexiCapture 9.0. But due to the numerous 

changes we recommend opening *.fsp project in FlexiLayout Studio 9.0, then checking that there are no errors 

and re-compiling it. 

 

6.4 Using FlexiCapture 8.0 Professional Projects (*.fcproj)  

All FlexiCapture 8.0 Professional project files (.fcproj) can be opened and used in FlexiCapture 9.0. Please note 

the following: 

- It is impossible to open an .fcproj-project in FlexiCapture 8.0 Professional once it was opened in FlexiCapture 

9.0, so create a copy of the project before opening it in FlexiCapture 9.0 if you still need to open it in 

FlexiCapture 8.0 Professional. 

- After opening a FlexiCapture 8.0 project in FlexiCapture 9.0 you may need to delete all processing results and 

analyze all pages once again. (You can use the project without re-recognizing, but some information may be 

presented improperly. For example, if the imported documents contains format errors, they will not be 

presented in the document window in the same way they are currently presented in FlexiCapture 9.0) 

 

6.5 Using FormReader 6.5 Batches (*.frm)  

All FormReader 6.5 batches (.frm) can be imported to FlexiCapture 9.0 by using the Document Definitions -> 

Import… command (from Administrator Station for Standalone and from Project Setup Station for Distributed). 
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Both fixed and flexible layouts with fields and their names are imported completely (except additional fields). All 

data types are imported as Custom data types of the document definition. 

Export settings, and images contained in the batch are not imported. Some of validation rules are converted 

automatically, the others have to be remade manually (see Сompatibility with FormReader 6.5 validation rules). 

An import log is created. 

Note! Batches created in versions earlier than 6.5 cannot be imported.  

6.6 Documents and Batches Structure    

If the document definition imported from FormReader 6.5 contains a custom structure which is not supported in 

FlexiCapture 9.0, a set of one-paged document definitions will be imported. 

1. Document templates with predefined structure (one-paged document, multi-paged documents, sequence 

of pages) are correctly converted into the document definitions for FC9 with the same structure. 

2. Custom document structure is not supported in FC90. Templates with custom structure will be converted 

into separate one-paged document definitions. 

3. If the structure of a batch was defined in FormReader 6.5 it will be ignored, the batch is considered as an 

arbitrary sequence of documents. 

 

6.7 Compatibility with FormReader 6.5 Validation Rules   

Support of FormReader 6.5 validation rules in FlexiCapture 9.0: 

FormReader 6.5 Equivalent in FlexiCapture 9.0  
Automatic 

conversion 

Check against a 

database 
“Database Check” rule 

No 

Check sums “Check Sum” rule No 

Merge blocks “Merge Fields” rule Yes 

Search in the list 

of suggestions 

Field properties, “Data Type” tab. List the variants of allowed values in the 

“Validation” field 

Yes 

Replace values 

from the list 
Field properties, “Data Type” tab. “AutoCorrect options” field 

Yes 

Replace 

characters from 

the list 

Field properties, “Data Type” tab. “AutoCorrect options” field 

Yes 
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Normalize and 

check dates 

Field properties, “Data Type” tab. In the “Content” list, select “Date”; in 

the “Content Details” dialog box, select the required formats; in the 

“Validation” field, enter the required constraints 

No 

Regular 

expressions 

Field properties, “Data Type” tab. In the “Content” list select “Text” or turn 

on the “Process value as text” checkbox for another content type. Enter 

the required regular expression in the “Validation” field. 

Yes 

Match blocks 
Can be implemented via a “Script” rule (see “Field match check” sample 

in Help) 

No 

If-Then rules 
Can be implemented via a “Script” rule (see Help for instructions on how 

to migrate) 

No 

Automation check 

Can be implemented via a “Script” rule  (see Help for instructions on how 

to migrate) 

If the logic of the rule is too complex and requires an external component 

to be used, the component should be called from within the code of a 

“Script” rule (see “Automation rule” sample in Help) 

No 

VBScript rules Can be implemented via a “Script” rule No 

Sum in digits - 

sum in writing 
“Sum in digits - sum in words” rule (for Russian language) 

No 

Normalize prices 

Not supported; can be implemented through an external COM component 

called from a “Script” rule 

 

Price in digits - 

price in writing 

No 

Validate passport 

series and 

number 

 

 

 

 

 


